Can't install on Win 7 64bit

Having problems trying to play Tribes Vengeance? Encountering crashes, can't get a HUD to work, ... ?
Post in here!
Post Reply
SirOllyBolly
Posts: 3
Joined: Tue Nov 17, 2015 4:36 pm

Can't install on Win 7 64bit

Post by SirOllyBolly » Tue Nov 17, 2015 4:41 pm

Hi folks,

I'm trying to install from my original TV disk onto Win 7 Ultimate 64 bit edition - but it just won't install.

The installer begins and gets to display the message "Removing applications..." next to the progress bar - and then just stops. I'm running the installer as Admin.

Has anyone installed this on Win 7 64?

Any suggestions welcome!

SirOllyBolly.

User avatar
Fifato
Posts: 68
Joined: Tue Mar 18, 2014 2:07 pm

Re: Can't install on Win 7 64bit

Post by Fifato » Tue Nov 17, 2015 5:53 pm

Hello and welcome

TV completely works on every system, doesnt matter if 32bit or 64bit.

OS isnt the problem here, maybe you have something in the registers from your earlier installation, but the possibilities of problems are endless.

The installer can be broken or even the data on the disk, but problems like these are common nowadays with old DVDs. It would be hard to find a solution without any more info.

If you know this stuff, then you can search for TV in the registers, delete everything and try again.

But there isnt anything easier than simply downloading Tribes Revengeance from here which I would very recommend. Its fully working repack and you dont have to bother with any installation process.


Fifato

HighDive
Revengeance Engineer
Posts: 567
Joined: Thu Mar 13, 2014 2:57 pm

Re: Can't install on Win 7 64bit

Post by HighDive » Tue Nov 17, 2015 6:17 pm

Hi!

As Fifato correctly said, your best bet is to use our installers from the website.

There are only two minor issues at play anymore here:

1) When the installation is finished you may get some error message considering a 'TV server browser'. This is an external, little program that simply displays the online game servers without you having to start up the game. The error message is there, because it is an older version and needs updating. The most recent version of this server browser can be found here: https://drive.google.com/folderview?id= ... XdmTVFaeG8 "TVServerBrowser.exe"

Note, however, that this program is not required to play T:V. As of such, you can choose to ignore this 'issue' and play the game anyway.

2) When trying to join a multiplayer server you will be prompted to use a valid CD-Key. Since you have an original copy of the game, I advice you to use that key. To solve this, simply browse to your Bin folder: ...\Tribes Vengeance\Program\Bin

Find an executable called 'tvkeychanger.exe' and run it as administrator. Enter the CD-Key found on your hard copy and press enter. Problems solved and ready to go!

-----------------------------------------------------------------------------

To complete my post, we are currently working on a new installer that does not have these issues. It is still a beta version so to speak, but relatively stable so far. We are currently trying to foolproof it in all possible situations and then distribute it. In case of interest, you can try downloading it from here: https://drive.google.com/file/d/0B_ITCf ... RzWVU/view

There should be no issues when using this installer. Mind you it is important to run it as administrator!

Hope this helps.

HighDive

User avatar
Fifato
Posts: 68
Joined: Tue Mar 18, 2014 2:07 pm

Re: Can't install on Win 7 64bit

Post by Fifato » Tue Nov 17, 2015 6:42 pm

If your own CD key wont work, choose a random one from here - http://tribesrevengeance.com/downloads/ ... v_keys.txt

SirOllyBolly
Posts: 3
Joined: Tue Nov 17, 2015 4:36 pm

Re: Can't install on Win 7 64bit

Post by SirOllyBolly » Wed Nov 18, 2015 5:38 pm

Thanks for the replies - but I've found the 'bug' - my own impatience!

The "Removing Applications" appeared for around 8 minutes before the install proceeded as normal - I was just too impatient!

TV now installed and working fine.

Thanks again,
SirOllyBolly

User avatar
Fifato
Posts: 68
Joined: Tue Mar 18, 2014 2:07 pm

Re: Can't install on Win 7 64bit

Post by Fifato » Wed Nov 18, 2015 5:46 pm

Nice to hear that :)

Anyways, you probably wont see any servers in the in-game server browser, since you installed the old 2004 release, you will maybe need to download the new engine.dll file (dont worry, small size) and put it in the Tribes Vengeance \ Program \ Bin folder. The engine.dll fix is here - http://tribesrevengeance.com/downloads/revengeance.php

Of course you can use direct IP connecting or different methods, which I am not sure if they even work right now, but this should make your things a lot easier.

Also you can get the TV server browser, which is a lightweight small utility that runs outside of TV, so you can track the servers without launching and it has an option to start the game and automatically join the server you want, just by clicking one button in the server browser.


Have fun !

Fifato

SirOllyBolly
Posts: 3
Joined: Tue Nov 17, 2015 4:36 pm

Re: Can't install on Win 7 64bit

Post by SirOllyBolly » Wed Nov 18, 2015 5:54 pm

Thanks Fifato - I'll try that in the next few days.

Regards,
SirOllyBolly

Post Reply