How to remove mouse acceleration?

Having problems trying to play Tribes Vengeance? Encountering crashes, can't get a HUD to work, ... ?
Post in here!
Post Reply
User avatar
Cobra
Revengeance Engineer
Posts: 116
Joined: Thu Mar 13, 2014 7:25 pm

How to remove mouse acceleration?

Post by Cobra » Tue Oct 07, 2014 5:32 pm

You may or may not have noticed it, but tribes vengeance does have some mouse acceleration. There is no option to disable this ingame though.

If you wish to remove the acceleration, you will need to add a few lines to your User.ini file located in your *\VUGames\Tribes Vengeance\Program\Bin folder.

Simply open your User.ini file, and search for: " [Engine.PlayerInput] "

Then add the following lines under " bInvertMouse=False " like so:

Code: Select all

[Engine.PlayerInput]

bInvertMouse=False
MouseAccelThreshold=0                        <- add these lines
MousesamplingTime=0.000001                   <-
MouseSmoothingMode=0                         <-
When you are done, save the changes and you will be able to play tribes with no mouse acceleration.


Edit: It is possible that your User.ini does not contain " [Engine.PlayerInput] " at all. If that is the case, simply add " [Engine.PlayerInput] " followed by the three new lines like shown in the preview.
Cobra ~ Cake

HighDive
Revengeance Engineer
Posts: 567
Joined: Thu Mar 13, 2014 2:57 pm

Re: How to remove mouse acceleration?

Post by HighDive » Sat Oct 11, 2014 1:53 pm

Thanks for this! I will add it to the website once I get some time!

HighDive

DiceRolla
Posts: 231
Joined: Sun Aug 03, 2014 11:10 pm

Re: How to remove mouse acceleration?

Post by DiceRolla » Thu Dec 18, 2014 8:12 pm

sooo I have been scouring all the inis and I have not found bInverMouse=False, or the [Engine.PlayerInput] in any of them. I also added at the bottom of the user ini the lines cobra posted, with proper spaces and so forth. However the mouse accel will not disable. On either the tribesrevengeance from the site or the disk install.

I did however find the setting for mouse accel in the tv_cd_dvd.ini

any thoughts?

User avatar
Cobra
Revengeance Engineer
Posts: 116
Joined: Thu Mar 13, 2014 7:25 pm

Re: How to remove mouse acceleration?

Post by Cobra » Thu Dec 18, 2014 9:06 pm

For some reason, The tribes configuration files do not contain all the lines that can be found in the source code. I am absolutely clueless as to why this happens though :/
It should, however, be enough to simply copy/paste the lines found in the source code into your configuration file. In your case, I can only guess you forgot to copy " [Engine.PlayerInput] " as well as the different lines right under it. (I should have clarified this in the main post)

As to why you found the acceleration setting in your tv_cd_dvd.ini and not in user.ini, I am not entirely sure. I actually have no way of knowing in which file the [Engine.PlayerInput] should be put. I just presumed it was in User.ini as I was lucky enough to find that very line in my original User.ini.

It is also possible that the game sees all the different config files as one big file, but I have to check on this
Cobra ~ Cake

DiceRolla
Posts: 231
Joined: Sun Aug 03, 2014 11:10 pm

Re: How to remove mouse acceleration?

Post by DiceRolla » Fri Dec 19, 2014 7:13 pm

Cobra wrote:For some reason, The tribes configuration files do not contain all the lines that can be found in the source code. I am absolutely clueless as to why this happens though :/
It should, however, be enough to simply copy/paste the lines found in the source code into your configuration file. In your case, I can only guess you forgot to copy " [Engine.PlayerInput] " as well as the different lines right under it. (I should have clarified this in the main post)

As to why you found the acceleration setting in your tv_cd_dvd.ini and not in user.ini, I am not entirely sure. I actually have no way of knowing in which file the [Engine.PlayerInput] should be put. I just presumed it was in User.ini as I was lucky enough to find that very line in my original User.ini.

It is also possible that the game sees all the different config files as one big file, but I have to check on this

I did add the engine.playerinput ( <--notlike that tho) and the following three lines, I've written programs by hand befor I understand the importance os things like that, however I do make mistakes.

Now I noticed with installing the Traquine brushes for hte editor, that the line your supposed to look for does not exsist in the associated ini, HOWEVER I found a similarily named line and added the brushes to it and it worked, so perhaps every install has the same lines, just expressed differently. perhaps you could copy the section from your ini and post it to here so I can look for similarities in my own ini?

like the entire section where you added the three lines.

because this is where I suspect it those lines would belong

[Gameplay.PlayerCharacterController]
zoomSpeed=0.750000
zoomLevel=1
radarZoomIndex=2
ChatWindowSizeIndex=1
SPChatWindowSizeIndex=0
bTeamMarkerColors=false
TimeMarginSlack=0.001000
InvExtCamOffset=(X=-200.000000,Y=0.000000,Z=210.000000)
bHideFirstPersonWeapon=False
MaxMessageTextLength=196
ChatSpamGuardEnabled=True
ChatSpamMaxMessages=4
ChatSpamThresholdTime=4.000000
ChatSpamMutePeriod=8.000000
EnemyTurnSpeed=45000
InputClass=Class'Engine.PlayerInput'
radarZoomScales=0.100000
radarZoomScales=0.350000
radarZoomScales=0.950000
zoomedFOVs=50.000000
zoomedFOVs=23.000000
zoomedFOVs=8.000000
zoomedMouseScale=0.750000
zoomedMouseScale=0.400000
zoomedMouseScale=0.100000
zoomMagnificationLevels=2.000000
zoomMagnificationLevels=4.000000
zoomMagnificationLevels=10.000000
ChatWindowSizes=4
ChatWindowSizes=6
ChatWindowSizes=12
SPChatWindowSizes=6

because at the very end of the ini I have this added

[Engine.PlayerInput]
MouseAccelThreshold=0
MousesamplingTime=0.000001
MouseSmoothingMode=0

witch did not remove the accel, I have also added it in different location on it's lonesome throught the use.ini with no affect

perhaps it's the missing enter? however the rest of my ini does not follow that format. ( an enter for that line of code would separate them wouldn't it? thus still rendering it useless? )

example

[Engine.PlayerInput]

MouseAccelThreshold=0
MousesamplingTime=0.000001
MouseSmoothingMode=0

User avatar
tapir
Posts: 49
Joined: Tue Mar 18, 2014 9:35 pm

Re: How to remove mouse acceleration?

Post by tapir » Fri Dec 19, 2014 9:15 pm

create new ini in content/system
paste this:

Code: Select all

SET playerInput MouseAccelThreshold 0
SET playerInput MousesamplingTime 0.000001
SET playerInput MouseSmoothingMode 0
SET playerInput MouseSensitivity 1
save
in tv shortcut at the end of target add: -exec=name.ini
run game and adjust mouse sens

User avatar
Cobra
Revengeance Engineer
Posts: 116
Joined: Thu Mar 13, 2014 7:25 pm

Re: How to remove mouse acceleration?

Post by Cobra » Sat Dec 20, 2014 12:30 pm

Tapir's method will indeed save us some hassle. (also the way I initialize your weapon skins btw, no need to type exec dice.ini in the menu anymore).

Anyway, this is a part of my user.ini:

Code: Select all

[antics_v3.anticsCharacterController]
radarZoomIndex=2
zoomSpeed=0.750000
ZoomLevel=1
ChatWindowSizeIndex=2
SPChatWindowSizeIndex=0
InvExtCamOffset=(X=-200.000000,Y=0.000000,Z=210.000000)
bTeamMarkerColors=False
bHideFirstPersonWeapon=True
MaxMessageTextLength=196
ChatSpamGuardEnabled=True
ChatSpamMaxMessages=4
ChatSpamThresholdTime=4.000000
ChatSpamMutePeriod=8.000000
EnemyTurnSpeed=45000
InputClass=Class'Engine.PlayerInput'
radarZoomScales=0.100000
radarZoomScales=0.350000
radarZoomScales=0.950000
zoomedFOVs=50.000000
zoomedFOVs=23.000000
zoomedFOVs=8.000000
zoomedMouseScale=0.750000
zoomedMouseScale=0.400000
zoomedMouseScale=0.100000
zoomMagnificationLevels=2.000000
zoomMagnificationLevels=4.000000
zoomMagnificationLevels=10.000000
ChatWindowSizes=5
ChatWindowSizes=8
ChatWindowSizes=30
SPChatWindowSizes=6

[Engine.Vehicle]
bVehicleShadows=True

[Engine.PlayerInput]
bInvertMouse=False
MouseSensitivity=3.000000
MouseAccelThreshold=0.000000
MouseSmoothingMode=0
MousesamplingTime=0.000001
;some extra stuff I still need to test
MouseSmoothingStrength=0.000000
DoubleClickTime=0.250000
bAdjustSampling=False

[UnrealGame.UnrealPawn]
bPlayerShadows=True
bBlobShadow=False 

[antics_v5.anticsCharacterController]
(same as [antics_v5.anticsCharacterController]. Only this one is used on servers running antics_v5 ofc)
Cobra ~ Cake

DiceRolla
Posts: 231
Joined: Sun Aug 03, 2014 11:10 pm

Re: How to remove mouse acceleration?

Post by DiceRolla » Sat Dec 20, 2014 4:17 pm

WOW your ini looks entirely different...how the hell does this game even work lol I will try Tapirs fix...it's not as much of an issue now that I've reinstalled, but it will certainly be nice for the weapon skins at least

User avatar
Cobra
Revengeance Engineer
Posts: 116
Joined: Thu Mar 13, 2014 7:25 pm

Re: How to remove mouse acceleration?

Post by Cobra » Sat Dec 20, 2014 7:05 pm

No idea :p

Anyway, I've found a good article about mouse technology, it does handle older games like UT2k3/4, so it might be useful for TV.
Here is the link: http://www.teamliquid.net/forum/tech-su ... technology
Cobra ~ Cake

DiceRolla
Posts: 231
Joined: Sun Aug 03, 2014 11:10 pm

Re: How to remove mouse acceleration?

Post by DiceRolla » Sat Dec 20, 2014 7:25 pm

  • [Engine.PlayerInput]
    SET playerInput MouseAccelThreshold=0
    SET playerInput MousesamplingTime=0.000001
    Set plaerInput MouseSmoothingMode=0
    SET playerInput MouseSensitivity 1350
soo thats the content of my "Mouse.ini"

eneabled with the " -exec=Mouse.ini"

works...almost seems like the mouse sense is actual pixels, I tested values all the way from 1 - 1500.

but oh my god is it smooth without mouse accel on holy hell

User avatar
Fireant
Revengeance Engineer
Posts: 143
Joined: Thu Mar 13, 2014 3:01 pm

Re: How to remove mouse acceleration?

Post by Fireant » Thu Dec 25, 2014 6:23 pm

Cobra wrote:For some reason, The tribes configuration files do not contain all the lines that can be found in the source code. I am absolutely clueless as to why this happens though :/
Settings in .ini files override defaultproperties block in unrealscript files. So if you dont explicitly set the variable in .ini file it will be taken from defaultproperties, so it should be safe to remove or add anything to .ini file because there is default value in the unrealscript anyways...

Oui
Posts: 103
Joined: Fri Mar 21, 2014 10:45 am

Re: How to remove mouse acceleration?

Post by Oui » Fri Dec 26, 2014 10:50 am

tapir's method works perfectly , feels so much smoother than by editing the user.ini

DiceRolla
Posts: 231
Joined: Sun Aug 03, 2014 11:10 pm

Re: How to remove mouse acceleration?

Post by DiceRolla » Tue Nov 24, 2015 1:05 am

coiuld changing this do much of anything I added a 0 after teh decimal and it feels different

MousesamplingTime=0.000001

Xenophon
Posts: 20
Joined: Sat Nov 21, 2015 6:04 pm

Re: How to remove mouse acceleration?

Post by Xenophon » Tue Nov 24, 2015 3:47 pm

Cobra wrote:You may or may not have noticed it, but tribes vengeance does have some mouse acceleration. There is no option to disable this ingame though.

If you wish to remove the acceleration, you will need to add a few lines to your User.ini file located in your *\VUGames\Tribes Vengeance\Program\Bin folder.

Simply open your User.ini file, and search for: " [Engine.PlayerInput] "

Then add the following lines under " bInvertMouse=False " like so:

Code: Select all

[Engine.PlayerInput]

bInvertMouse=False
MouseAccelThreshold=0                        <- add these lines
MousesamplingTime=0.000001                   <-
MouseSmoothingMode=0                         <-
When you are done, save the changes and you will be able to play tribes with no mouse acceleration.


Edit: It is possible that your User.ini does not contain " [Engine.PlayerInput] " at all. If that is the case, simply add " [Engine.PlayerInput] " followed by the three new lines like shown in the preview.
Is mouse accelation bad?

Hawk
Posts: 94
Joined: Mon Mar 17, 2014 10:43 pm

Re: How to remove mouse acceleration?

Post by Hawk » Tue Nov 24, 2015 3:49 pm

It is up to personal preference, some players feel they can make more accurate movements when moving the mouse fast when the acceleration is disabled.
General of cheating.
Admiral of destruction.
Marshall of corruption.

Oui
Posts: 103
Joined: Fri Mar 21, 2014 10:45 am

Re: How to remove mouse acceleration?

Post by Oui » Tue Nov 24, 2015 7:24 pm

you simply have more control. If you are like in the middle of the action and you do some fast , unexpected move with your mouse it's more likely you will hit without mouse accel , because the sensitivity stays the same no matter how fast you move your mouse , while with mouse accel on you can over-aim while doing fast motions

DiceRolla
Posts: 231
Joined: Sun Aug 03, 2014 11:10 pm

Re: How to remove mouse acceleration?

Post by DiceRolla » Tue Nov 24, 2015 11:45 pm

I discovered that mouse accel simpley makes pixels (for lack of a btter word) laterger to increase the mouse speed rather than just increasing the speed of travel over more pixels

like lets say your DPI (dots per inch) is set to 1200, you turn up your ingame mosue speed (mouse accel) it dosen't make your DPI go up it makes your dots bigger and lowers your DPI, effectively creating areas you literally cannot aim at on the screen, most noticeable when zoomed in against a still object and moving the mouse slowly.

I know this isn't the technical explanation but it's the only metaphor I can come up with that explains it

Post Reply